Joomla Versions Compatibility

Revision as of 02:40, 20 September 2017 by Sinisakrisan (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

As code bases for both, Joomla! Project and JomSocial evolve with every new day, it is imperative for users to know what versions of Joomla and JomSocial can be paired.
Bellow is the JomSocial compatibility table which explains what versions you can use on Your Joomla based site.

Joomla 4.x
JomSocial
Compat icon 4 0 long.png
TBA
Joomla 3.x
JomSocial
Compat icon 3 8 long.png
JomSocial 4.4
Compat icon 3 7 long.png
Minimum jomSocial 4.3.2 or JomSocial 4.4
Compat icon 3 6 long.png
Minimum JomSocial 4.2.3 or JomSocial 4.3.x
Compat 35.png
Any version of JomSocial 4.2.x
Compat 34.png
Any version of JomSocial 4.0.x and 4.1.x
Compat 33.png
Any version of JomSocial 3.2.x
Compat 32.png
Any version of JomSocial 3.1.x
Compat 31.png
Any version of JomSocial 3.0.x
Compat30.png
Any version of JomSocial 3.0.x
Joomla! 1.5; 1.6; 1.7; 2.5
JomSocial
Compat15.png
You can install all JomSocial versions from 1.0.x to 2.6.3 on Joomla! 1.5
Compat16.png
Only versions 2.2.x 2.4.x and 2.6.x can be installed on Joomla! 1.6
Compat17.png
Only versions 2.2.x 2.4.x and 2.6.x can be installed on Joomla! 1.7
Compat25.png
On Joomla! 2.5 you can install following versions: 2.6.x, 2.8.x, 3.0.x, 3.1.x, 3.2.x, 4.0.x and 4.1.x

What versions of Joomla will be supported in the future?

This is the list of Joomla versions that JomSocial will support.

  • Joomla 4.x - We aim for the day one full compatibility as soon as Joomla 4 becomes available
  • Joomla 3.x - JomSocial will be compatible with Joomla 3.x as long as Joomla actively develop this version.
  • Joomla 2.5 - lost our support on December 22. 2016. (two years after official end of life)
  • Joomla 1.5 lost our support on January 1. 2013 (almost 8 months after official end of life announcements in April 2012 and 4 months after extended support in September 2012)

JomSocial Support Lifetime

Only current and previous versions are supported by our team.

See Also